Installation Metasploit Framework 3.3.3 on GNU/Linux Debian Lenny

Dependencies:

# apt-get install ruby libopenssl-ruby libyaml-ruby libdl-ruby libiconv-ruby libreadline-ruby irb ri rubygems subversion ruby-dev libpcap-dev libsqlite3-dev

# apt-get build-dep ruby

# gem install sqlite3-ruby

Framework:

# tar -xvvjf framework-3.3.3.tar.bz2

# mkdir -p /opt/metasploit3

# cp -a msf3/ /opt/metasploit3/msf3

# chown root:root -R /opt/metasploit3/msf3

# ln -sf /opt/metasploit3/msf3/msf* /usr/local/bin/

Continue reading

Advertisements